HƯỚNG DẪN SỬ DỤNG HANOSOFT 3

HƯỚNG DẪN SỬ DỤNG HANOSOFT 3.0

1. Tổng quát

Hanosoft 3.0 là version nối tiếp các phiên bản Hanokey và Hanosoft trước đây. Phiên bản lần này được được bổ sung các tính năng mới như:

Ø Dữ liệu mở ở định dạng Ms Access, cho phép cập nhật dữ liệu theo nhu cầu cá nhân.

Ø Từ điển tổng hợp. Ngoài từ điển có sẵn, người dùng có thể thêm vào các từ điển của mình.

Ø Tra tự điển Nôm. Hỗ trợ tra chữ Nôm theo 2 phương thức: tra theo chữ quốc ngữ và tra theo bộ thủ.

Ø Hanosoft Reader gồm các chức năng phiên âm văn bản Hán và tra nghĩa của chữ ngay trong văn bản.

Bộ gõ Hanosoft 3.0 được dùng chung với Microsoft Word. Do đó cần cài bộ Microsoft Office để dùng được chương trình này.

Khi chạy chương trình, hộp thoại chính sẽ hiển thị gồm có 4 nút lệnh:

- Hán Input: gõ chữ Hán từ chữ quốc ngữ theo âm Hán Việt.

- Nôm Input: gõ chữ Nôm từ chữ quốc ngữ theo âm Hán Việt và thuần Việt.

- Dictionary: các chức năng tra từ điển gồm tự điển Nôm và các tự, từ điển Hán.

- Reader: các chức năng hoán chuyển văn bản chữ Hán sang âm Hán Việt.

2. Gõ chữ Hán (Hán Input)

Gõ chữ âm Hán Việt vào khung nhập chữ bên trái. Các chữ Hán sẽ hiện ra trên các ô vuông bên phải. Nhấp chuột hoặc gõ phím F1, F2… F12 ở vị trí ký tự cần nhập.

Khi số ký tự Hán vượt quá 12 ký tự thì chọn nút sang trang [ >] để xem các ký tự còn lại.

Lưu ý: Chữ gõ vào phải bỏ dấu theo lối chính tả.Ví dụ: phải gõ hoà, hoả, thuý, tuý thay vì gõ hòa, hỏa, thúy, túy. (nếu không gõ được thì cần chỉnh lại cấu hình của keyboard tiếng Việt như Vietkey, Unikey v.v.).

Thanh gõ chữ này được dùng chung với Microsoft Word. Sau khi chọn, ký tự Hán sẽ được nhập trực tiếp vào văn bản Word. Nếu sử dụng phần mềm soạn thảo không phải Word thì chọn nút Expand để thực hiện việc trung chuyển.

3. Gõ chữ Nôm (Nôm Input)

Tương tự như việc gõ chữ Hán. Tuy nhiên có sự phức tạp đôi chút về font chữ Nôm như sau:

- Font ký tự quốc tế phổ thông hiện nay là Arial Unicode MS, có chứa đủ các chữ Hán thông dụng. Tuy nhiên, font này không chứa đầy đủ các chữ Nôm, cho nên khi gõ nếu thấy chữ không hiện ra (mặc dù có hiện mã Unicode) hoặc chỉ hiện ô vuông thì cần phải đổi sang font khác trong danh sách font.

- Bộ font Han Nom A và Han Nom B do Ts. Chân Nguyên Đỗ Quốc Bảo, Tô Minh Tâm và ni sinh thiền viện Viên Chiếu phát triển. Một phần chữ Nôm nằm ở font Han Nom A và một phần nằm ở font Han Nom B. Do đó, cần phải chuyển đổi qua lại giữ 2 font để thể hiện chữ Nôm đã gõ.
Font này đã được đưa và sử dụng theo giấy phép GNU General Public License, có thể download tại địa chỉ: http://vietunicode.sourceforge.net/fonts/fonts_hannom.html

- Bộ font Nôm Na Tong do nhóm Nôm Na phát triển. Font này thể hiện chữ Nôm trên văn bản khá rõ nét. Bộ font này có thể download tại địa chỉ: http://nomna.org/

- Danh sách font Nôm trên thanh nhập có thể thay đổi dễ dàng bằng cách mở file dữ liệu của Hanosoft (trong folder cài đặt). Sau đó mở Table: tbl_font_Nom và cập nhật lại tên font theo ý của mình.

4. Sử dụng từ điển (Dictionary)

Từ điển Hanosoft bao gồm nhiều chức năng tra chữ Hán và chữ Nôm. Sau đây là các phần hướng dẫn từng mô-đun của chức năng tra từ điển.

a) Tra từ đơn

Ở đây (Hanosoft) quy ước từ đơn tức là từ ứng với một ký tự Hán hoặc Nôm.

Để tra từ đơn, chúng ta sử dụng mô-đun trong hình minh họa sau:

- Hanviet: Tra từ đơn theo âm Hán Việt (chữ Quốc ngữ).

- Pinyin: Tra theo âm tiếng Phổ thông (bính âm Trung Quốc).

- Korean: Tra theo âm Hàn Quốc.

- Japanese: Tra theo âm Nhật Bản.

- 4 conners: Tra theo tứ giác hiệu mã.

- Radical ID: Tra theo 214 bộ thủ.

Khi tra toàn bộ chữ Hán cần tìm sẽ được liệt kê trên bảng kẻ ô ở phía trên.

b) Tra từ phức:

Từ phức được quy ước ở đây là từ gồm 2 ký tự Hán trở lên.

Gõ từ phức theo âm Hán Việt vào ô tra, sau đó chọn OK. Tất cả các từ phức đồng âm sẽ thể hiện trên bảng danh sách.

Lưu ý: chức năng trên cũng có thể được dùng để tra từ đơn, tuy nhiên chữ Hán thể hiện trên bảng danh sách sẽ khó tìm hơn so với cách thể hiện trên bảng kẻ ô.

c) Tra theo ký tự Hán

Để nhập chữ Hán vào ô tra từ chúng ta có thể dùng một trong các cách sau:

- Gõ trực tiếp: Sử dụng IME hệ thống (của Microsoft chẳng hạn) nhập thẳng chữ vào ô tra từ.

- Chọn từ bảng kẻ ô: Để sử dụng chức năng này, cần phải đánh dấu Catch script s. Sau khi đã đánh dấu, người dùng có thể bấm từng chữ trên bảng kẻ ô để chuyển xuống ô tra này.

- Tra chữ đã copy: Nếu chữ Hán đã được copy từ văn bản khác, trên website chẳng hạn, thì trước hết nhấp đôi chuột vào ô tra để xoá chữ cũ đi, rồi nhấp OK để import chữ đã copy vào.

d) Tra chữ Nôm

Có thể tra chữ Nôm theo 2 cách:

- Tra theo chữ Quốc ngữ: Gõ chữ vào ô tra, các chữ Nôm cùng âm sẽ thể hiện trên bảng kẻ ô.

- Tra theo bộ thủ: Chọn nút lệnh Nôm Radical ID, sau đó đó chọn bộ thủ mà chữ Nôm cần tra có chứa nó.

f) Sử dụng bảng kẻ ô:

Bảng kẻ ô dùng để thể hiện các chữ Hán cùng âm (hoặc cùng bộ thủ) khi tra từ đơn hoặc tra chữ Nôm. Trong bảng này, người dùng chỉ việc nhấp chuột trên ký tự cần tra, nội dung của ký tự đó sẽ xuất hiện ở phần bên phải bảng kẻ ô bao gồm:

1 – Thể hiện chữ ở chế độ zoom lớn, kèm theo mã Unicode, âm Hán, Nôm, Pinyin, Nhật, Hàn của ký tự đó.

2 – Thể hiện nghĩa của ký tự đó. Nghĩa này được tổng hợp từ 2 quyển tự điển Thiều Chửu và Trần Văn Chánh.

3 – Trong bảng danh sách bên phải sẽ liệt kê mục tra ký tự này trong tất cả các từ điển khác (từ điển có sẵn và từ điển add-in), và tất cả các mục từ phức bắt đầu bằng ký tự này.

f) Sử dụng danh sách liệt kê:

Danh sách liệt kê mục từ nằm ở bên phải bảng tra từ điển. Kết quả các mục từ trên danh sách này có được qua việc thực hiện tra như đã trình bày ở trên:

1- Nhấp chuột vào chữ ở bảng kẻ ô ở bên trái.

2- Tra theo ký tự Hán (tại ô tra Chinese Scripts)

3- Tra từ phức (nhập chữ Hán Việt tại ô Compound Word).

Khi nhấp chuột vào từ cần tra trên bảng thì nghĩa của từ đó sẽ được thể hiện trên một hộp thoại mới:

Trong khung hiển thị nghĩa, nếu có chữ Hán chưa rõ nghĩa, chúng ta có thể nhấp chọn chữ Hán để tra nghĩa của riêng chữ Hán đó. Nghĩa sẽ thể hiện ở phần bên trái hộp thoại này.

Đối với một số từ điển Hán – Hán (tức phần giải nghĩa chỉ chứa toàn chữ Hán) chúng ta có thể sử dụng chức năng trợ giúp phiên âm bằng cách nhấp nút lệnh Transliterate.

Ø Nút lệnh Copy SelText dùng để copy chữ đã được quét chọn trên văn bản giải nghĩa.

Ø Nút lệnh Copy All dùng để copy toàn bộ văn bản giải nghĩa.

Ø Nút lệnh Close để đóng hộp thoại giải nghĩa.

5. Sử dụng công cụ đọc văn bản Hán (Hanosoft Reader)

Chức năng Convert dùng để phiên âm chữ Hán sang âm Hán Việt. Ngoài ra chức năng này còn giúp việc biên dịch và học tập chữ Hán được dễ dàng hơn.

Cách sử dụng như sau:

  1. Copy văn bản chữ Hán từ nguồn bất kỳ.
  2. Nếu văn bản đó là phồn thể thì để mặc định, nếu là giản thể thì chọn nút Simplified.
  3. Bấm một trong 3 nút để thực hiện thao tác:

Ø Original text: Chỉ thực hiện việc Paste và giữ nguyên văn bản chữ Hán.

Ø Converter1: Thực hiện hoán chuyển văn bản Hán theo dạng cắt đoạn: Một đoạn chữ Hán và một đoạn chữ Hán Việt.

Ø Converter2: Thực hiện hoán chuyển toàn bộ văn bản Hán sang âm Hán Việt.

Người dùng có thể nhấp chọn chữ Hán trong khung hoán chuyển để tra nghĩa của chữ đó. Phần nghĩa sẽ hiển thị ở phần bên trái hộp thoại.

Ø Nút lệnh Copy SelText dùng để copy chữ đã được quét chọn trên văn bản đã hoán chuyển.

Ø Nút lệnh Copy All dùng để copy toàn bộ văn bản.

6. Làm việc với Cơ Sở Dữ Liệu

Dùng Microsoft Access để mở file hanosoft.mdb (file này nằm trong folder cài chương trình, thông thường là C:\Program Files\Hanosoft)

Một số table quan trọng:

Ø tbl_dict_han: Tự điển Hán-Việt, dữ liệu gốc gồm tự điển Thiều Chửu (tc) và Trần Văn Chánh (tvc).

Ø tbl_dict_nom: Tự điển chữ Nôm, dữ liệu gốc là tự điển Nôm của Hội Bảo Tồn Di Sản chữ Nôm cung cấp (hiện chưa cập nhật).

Ø tbl_dictionary: Từ điển Tổng hợp, dữ liệu gốc là tự điển Thiều Chửu, Trần Văn Chánh và các bộ từ điển Phật học miễn phí.

Ø tbl_radical: Dữ liệu 214 bộ thủ chữ Hán.

Ø tbl_radical_result: Dữ liệu thống kê phân loại bộ thủ cho các chữ Hán.

Ø tbl_radical_nom: Dữ liệu 214 bộ thủ chữ Nôm.

Ø tbl_radical_result: Dữ liệu thống kê phân loại bộ thủ cho các chữ Nôm.

Ø tbl_han: Dữ liệu bộ gõ chữ Hán.

Ø tbl_nom: Dữ liệu bộ gõ chữ Nôm.

Ø tbl_hanvietsim: Dữ liệu bộ converter giản thể.

Ø tbl_hanviettra: Dữ liệu bộ converter phồn thể.

7. Lưu ý khi tra chữ Nôm

Khi chuyển sang chức năng tra chữ Nôm, các ký tự thể hiện trên bảng kẻ ô sẽ có màu nền khác hơn so với màu thông thường. Khi nhấp vào các chữ này thì nghĩa Nôm của chúng sẽ được hiển thị (hiện từ điển Nôm chưa có nội dung, người dùng có thể cập nhập trong tbl_dict_nom).

Nếu các chữ Nôm trên bản kẻ ô không thể hiện (mặc dù vẫn hiện màu nền) hoặc chỉ hiện ô vuông, khi đó chúng ta cần đổi sang font chữ khác để thể hiện chúng.

Tôi xin chân thành cám ơn những vị sau:

Học giả Lê Anh Minh, Trần Văn Chánh, Ts. Bùi Khởi Giang, Ts. Đỗ Quốc Bảo, Ts. Ngô Trung Việt, Ts. Ngô Thanh Nhàn đã giúp đỡ, góp ý, chia sẻ dữ liệu trong thời gian tôi phát triển phần mềm này.

20/11/2011
Tống Phước Khải

==========================================

- Các thông tin chi tiết về Hanosoft và một số phần mềm khác được post tại http://tongphuockhai.wordpress.com

CÁC PHẦN MỀM KHÁC CỦA CÙNG TÁC GIẢ:

- Siddhamkey: Bộ gõ chữ Phạn Siddham và Ranjana và từ điển Sanskirt.

- Pali Dictionary: Bộ từ điển tổng hợp tra tiếng Pali ra nhiều ngôn ngữ khác.

- Sanskrit Dictionary: Từ điển tra tiếng Sanskrit dữ liệu là từ điển Monier Williams.

- Uchen TPK keyboard: Keyboard gõ chữ Tây Tạng dùng cho tiếng Sanskrit, Pali.